Jump to content



Photo
- - - - -

Rockstar on Grand Theft Auto IV PC issues


  • Please log in to reply
12 replies to this topic

#1 Chris

Chris

    Limbal Rings

  • Administrators
  • 10,941 posts

Posted 03 December 2008 - 11:59 PM

Rockstar have sent us a message regarding the issues some people are experiencing on their installations of Grand Theft Auto IV. They are advising people having problems to contact their local technical support helpline, or use Rockstar's online support page.

Hey guys,

We are aware that a small number of fans are having problems running GTA IV on their PC’s and we would like to assure them we are working to help solve these as quickly as possible.

We would ask anyone that is encountering difficulties to contact their local technical support helpline for advice and recommendations. These telephone numbers can be found in the game’s manual.

There is also a regularly updated technical support page available on the Rockstar Games website http://www.rockstargames.com/support/ where there are many useful faqs and information on how to resolve some common problems being encountered.

Thanks,

Webmaster@R*



#2 The Commander

The Commander

    Scam Artist

  • Members
  • Pip
  • 62 posts
  • New Zealand 

Posted 04 December 2008 - 03:10 AM

Small Number Of Fans??? WTF!?!
Is that a joke, cos I ROFL when I read that bit.

#3 Chris

Chris

    Limbal Rings

  • Administrators
  • 10,941 posts

Posted 04 December 2008 - 03:18 AM

As does everyone else. I'm surprised they phrased it like that because forums across the web are rife with people complaining about how poorly it's running on their systems.

The main point to take from their message is that they are working to solve all the problems, so we can hope that a patch is released soon.

#4 Ruud2000

Ruud2000

    Nobody Special

  • Members
  • 3 posts
  • Netherlands 

Posted 04 December 2008 - 09:58 AM

Rockstar have sent us a message regarding the issues some people are experiencing on their installations of Grand Theft Auto IV. They are advising people having problems to contact their local technical support helpline, or use Rockstar's online support page.

Hey guys,

We are aware that a small number of fans are having problems running GTA IV on their PC’s and we would like to assure them we are working to help solve these as quickly as possible.

We would ask anyone that is encountering difficulties to contact their local technical support helpline for advice and recommendations. These telephone numbers can be found in the game’s manual.

There is also a regularly updated technical support page available on the Rockstar Games website http://www.rockstargames.com/support/ where there are many useful faqs and information on how to resolve some common problems being encountered.

Thanks,

Webmaster@R*




Hi there,

After waiting for many years on GTAIV for the PC I installed it. It took me 1 hour, and after several online registrations I restarted my PC and the game crashed and getting error code mma10.

And this is the only thing Rockstar can say about it??? :thumbsdown:

“We are aware that a small number of fans are having problems running GTA IV on their PC’s”

This is bullsh*t. All we can see is a overload of GTA form messages of users with the same problems.

“We would ask anyone that is encountering difficulties to contact their local technical support helpline for advice”
In my case this was not possible. I called a 0900 number (0,80 euro p/m) and after 20 minutes a lady told me all support guys are in a congress or something. This phone call cost me 16 euro! I send a email to the UK support, and still no answer.

“There is also a regularly updated technical support page available on the Rockstar Games website”

I go to that website, and searching for the error code mma10 and without any result. Error mma10 is the biggest problem that many users have. They must know it, why is there still no solution?

It looks this PC game is not good tested. If you have a Windows XP/Vista version with a other language than standard, the install dialog and buttons are empty!

By the way, it looks like you need a mega PC to run the game. I have a Dualcore 2400 (2GB mem) and Geforce 9600 and it runs, but with the game quality on mid. I have installed windows XP SP3 on a complete clean machine with. Games as Tomb raider or Need for Speed Undercover I can run on the highest resolution without any problems.

#5 Chris

Chris

    Limbal Rings

  • Administrators
  • 10,941 posts

Posted 04 December 2008 - 11:32 AM

To fix the MMA10 error just sign out of Social Club.

#6 Mehhh

Mehhh

    Trickster

  • Members
  • Pip
  • 95 posts
  • United States 

Posted 04 December 2008 - 06:15 PM

Hi there,

After waiting for many years on GTAIV for the PC I installed it. It took me 1 hour, and after several online registrations I restarted my PC and the game crashed and getting error code mma10.

And this is the only thing Rockstar can say about it??? :thumbsdown:

“We are aware that a small number of fans are having problems running GTA IV on their PC’s”

This is bullsh*t. All we can see is a overload of GTA form messages of users with the same problems.

“We would ask anyone that is encountering difficulties to contact their local technical support helpline for advice”
In my case this was not possible. I called a 0900 number (0,80 euro p/m) and after 20 minutes a lady told me all support guys are in a congress or something. This phone call cost me 16 euro! I send a email to the UK support, and still no answer.

“There is also a regularly updated technical support page available on the Rockstar Games website”

I go to that website, and searching for the error code mma10 and without any result. Error mma10 is the biggest problem that many users have. They must know it, why is there still no solution?

It looks this PC game is not good tested. If you have a Windows XP/Vista version with a other language than standard, the install dialog and buttons are empty!

By the way, it looks like you need a mega PC to run the game. I have a Dualcore 2400 (2GB mem) and Geforce 9600 and it runs, but with the game quality on mid. I have installed windows XP SP3 on a complete clean machine with. Games as Tomb raider or Need for Speed Undercover I can run on the highest resolution without any problems.

'Ruud2000'



Wow Ruud, I'm sorry you had such negative experiences. I've sent email and attachments to T2, not heard back yet ..
I was getting some kind of picture at first but it was a lil sketchy, so I tried changing settings & it has been way messt up since..

See here

http://img235.images...ash1copyel7.jpg

http://img235.images...ash2copysi7.jpg

Nothing can I do to change the settings to make it any different, at the beginning of the game, all I see is the car taillights and everything is blue water & pieces of things ..

Your system sounds very similar to mine, I have a 9600 GT 512MB and the latest drivers, DX 10, Vista Premium and 2GB BUT the game label on my box says recommended settings, XP 2GB, Vista 2.5GB, (graphics Nvid 8600 & our cards are better than that so) now I've been thinking is it just cuz I dont have that extra .5GB+ ..

I've been finding alotta ppl have 4GB mem so maybe it is system mem, I'm hoping to hear back from T2..

I've also been abit tickt by the fact of having to do all that busy work too, registrations, sign into WLive JUST to save, that dogon social club sign in never fails to pop up and reports messages in-game, that is awful, I understand for online play but not if we jus want to play offline we can't even save w/ out sign-in..

INteresting I never seen any of those as requirements mentioned b4 the game was released, it was about graphics, the editor etc.. I wish they'd gave us the full story on that sign-in business, if they did someplace, I simply never saw it in all the reviews posted by popular mags/sites. I liked the VC & SA, load/play/save.. thats it. Its still my fav game, I jus hope I can fix whatever is causing those problems ...

Edited by Mehhh, 04 December 2008 - 06:18 PM.

Vista Premium 32bit
Dual core 2.6GHz
2GB DDR2
9600GT 512MB
Native Res 1440x900

#7 Ruud2000

Ruud2000

    Nobody Special

  • Members
  • 3 posts
  • Netherlands 

Posted 05 December 2008 - 08:44 AM

Hi there,

After waiting for many years on GTAIV for the PC I installed it. It took me 1 hour, and after several online registrations I restarted my PC and the game crashed and getting error code mma10.

And this is the only thing Rockstar can say about it??? :thumbsdown:

“We are aware that a small number of fans are having problems running GTA IV on their PC’s”

This is bullsh*t. All we can see is a overload of GTA form messages of users with the same problems.

“We would ask anyone that is encountering difficulties to contact their local technical support helpline for advice”
In my case this was not possible. I called a 0900 number (0,80 euro p/m) and after 20 minutes a lady told me all support guys are in a congress or something. This phone call cost me 16 euro! I send a email to the UK support, and still no answer.

“There is also a regularly updated technical support page available on the Rockstar Games website”

I go to that website, and searching for the error code mma10 and without any result. Error mma10 is the biggest problem that many users have. They must know it, why is there still no solution?

It looks this PC game is not good tested. If you have a Windows XP/Vista version with a other language than standard, the install dialog and buttons are empty!

By the way, it looks like you need a mega PC to run the game. I have a Dualcore 2400 (2GB mem) and Geforce 9600 and it runs, but with the game quality on mid. I have installed windows XP SP3 on a complete clean machine with. Games as Tomb raider or Need for Speed Undercover I can run on the highest resolution without any problems.

'Ruud2000'



Wow Ruud, I'm sorry you had such negative experiences. I've sent email and attachments to T2, not heard back yet ..
I was getting some kind of picture at first but it was a lil sketchy, so I tried changing settings & it has been way messt up since..

See here

http://img235.images...ash1copyel7.jpg

http://img235.images...ash2copysi7.jpg

Nothing can I do to change the settings to make it any different, at the beginning of the game, all I see is the car taillights and everything is blue water & pieces of things ..

Your system sounds very similar to mine, I have a 9600 GT 512MB and the latest drivers, DX 10, Vista Premium and 2GB BUT the game label on my box says recommended settings, XP 2GB, Vista 2.5GB, (graphics Nvid 8600 & our cards are better than that so) now I've been thinking is it just cuz I dont have that extra .5GB+ ..

I've been finding alotta ppl have 4GB mem so maybe it is system mem, I'm hoping to hear back from T2..

I've also been abit tickt by the fact of having to do all that busy work too, registrations, sign into WLive JUST to save, that dogon social club sign in never fails to pop up and reports messages in-game, that is awful, I understand for online play but not if we jus want to play offline we can't even save w/ out sign-in..

INteresting I never seen any of those as requirements mentioned b4 the game was released, it was about graphics, the editor etc.. I wish they'd gave us the full story on that sign-in business, if they did someplace, I simply never saw it in all the reviews posted by popular mags/sites. I liked the VC & SA, load/play/save.. thats it. Its still my fav game, I jus hope I can fix whatever is causing those problems ...


Hi Mehhh,

The pictures certainly look weird and never seen with my configuration. On this moment I’m somewhere else so I can’t check my video driver version number, but I downloaded my Nvidia driver 2 weeks ago.

I can not imagine that the internal memory gives this video problem.

The only main difference is I’m running the game on Windows XP. When the game is started there is a total mem of 1.3GB in use. I know Vista use a lot more memory than XP. Maybe there is someone here who can tell us how much mem is in use on Vista when the game is started.

For the people who don’t know how to check: just start the game, play it, and hit the ALT-TAB and open windows Task-Manager (CTRL-ALT-DEL).

#8 Earthbound

Earthbound

  • Elite Members
  • 950 posts
  • Australia 

Posted 05 December 2008 - 01:19 PM

I'm really very surprised by all of this - this debacle has really put an axe into my opinion of Rockstar. Not that it matters - they'll do fine without my money, but it is disappointing to see how many avid GTA gamers are given such a poor message - there is no real information given or whether they've had any progress in resolving these issues. I'm also surprised that it has taken such an extent of time for them to get up off their backsides to attempt to fix these errors. Surely it couldn't be all that hard for a team of high skilled developers that are capable of creating a game such as Grand Theft Auto 4.

Poor development and minimal testing. This is to blame. Though, you could hardly say it was rushed - it took quite some time to get it out onto PC. I guess ghosting a game from one platform to another takes a while these days.

Disappointing.

Edited by Earthbound, 05 December 2008 - 01:20 PM.

Posted Image
I hate to be the one to break it to you, but a clear conscience
is generally the result of a faulty memory, not a faultless life.
Want a new sig? Click here!
GET ON MTA


#9 WRX22B1998

WRX22B1998

    like a Boss

  • Elite Members
  • 2,592 posts

Posted 05 December 2008 - 01:31 PM

lol yeah, i mean , the other GTA's had barely any problems iirc. maybe cos of lower requirements :P

i dunno though, they mostly ran fine with no probs. except vice city (and gta3) would get "unhandled exception" out of the blue...why it wasn't handled i dunno lol.

#10 Earthbound

Earthbound

  • Elite Members
  • 950 posts
  • Australia 

Posted 05 December 2008 - 01:34 PM

lol yeah, i mean , the other GTA's had barely any problems iirc. maybe cos of lower requirements :P

i dunno though, they mostly ran fine with no probs. except vice city (and gta3) would get "unhandled exception" out of the blue...why it wasn't handled i dunno lol.

Lol, those bloody handlers weren't doing their job I suppose.

Usually that error occurred if you had a dud modification installed, but I had never had the issue until I went to XP. I was a Windows 98 SE man until about 3 years ago. Ahh, the good old days.

Posted Image
I hate to be the one to break it to you, but a clear conscience
is generally the result of a faulty memory, not a faultless life.
Want a new sig? Click here!
GET ON MTA


#11 WRX22B1998

WRX22B1998

    like a Boss

  • Elite Members
  • 2,592 posts

Posted 05 December 2008 - 01:37 PM

lol windows 98. yeh we jumped from 98 to XP...well, the computer that had 98 became the XP computer. 533mhz celeron with 128 ram and a 10gb hard drive. or was it 5. lol. it was terrible.

yeah i know, but this was out of the blue, maybe the trainer decided to fk the game up.

but yeah i see people (like captain318 or whatever) posting how he goes with gta, and his specs, its unbelievable. yet another reason i will probs get a ps3 instead of a pc.

#12 Earthbound

Earthbound

  • Elite Members
  • 950 posts
  • Australia 

Posted 05 December 2008 - 01:40 PM

I've got a shite PC, but I have a PS3 which does the gaming bit just nicely. Though, GTA4 still sucked on that. Mandatory updates are a pain in the arse.

Posted Image
I hate to be the one to break it to you, but a clear conscience
is generally the result of a faulty memory, not a faultless life.
Want a new sig? Click here!
GET ON MTA


#13 Mehhh

Mehhh

    Trickster

  • Members
  • Pip
  • 95 posts
  • United States 

Posted 10 December 2008 - 04:18 AM

Ruud, actually there is some dispute over "mem useage" in Vista/XP, Xp has prefetch, Vista has superfetch. I'm not sure if Xp caches that in memory or in virtual... I know Vista uses superfetch to load things into memory that based on "useage characteristics" win "thinks" you will most likely need so they are already in memory, giving some performance enhancement. Ppl will notice in performance tab, how it loox like they are OUT of or nearly out of memory, the claim is, w/ superfetching, its filled much of the memory w/ data so other than lookin at processes, you dont know what is takin up how much...

Well, when I run the game, I noticed tween 1.6GB to 1.85/.95GB being used, thats almost ALL mem, only have 2 GB .. So I thought that might be a problem, also noticing many other folks have 4GB .. Thats not the game using it all but w/ all the processes of the game, I'd say it uses most of it.. I know the main exe uses lil over 1GB .. Rest is social club I think that useless thing is like 30-40MB :rolleyes:

" "unhandled exception" out of the blue...why it wasn't handled i dunno lol." Havent you been payin attention to the world economy !! They were tryin to cut costs, thats why it dint have a handle :lolbounce:

Wow, I remember Apple pc's in school w/ the 5¼ floppies, I can still hear the racket from that thing .. My first pc when I was lil was a Tandy 2100, 100 MHz Intel .. I can't member if hmm, was a 255MB HD, win 3.1, I think it had 32 or 64MB SIMM. I ruined it too, or so I thought as a kid, so naturally I had to open it up & see what all the goodies were inside :P My, ahem, interest in silicone started from there!

Yea console is better for the gameplay for me just cuz I'm used to it and its a gaming system primarily, well atleast games like this.. Half life, C&C etc I'm better w/ on pc, course you can install mods in them w/ out BS!!

Edited by Mehhh, 10 December 2008 - 04:19 AM.

Vista Premium 32bit
Dual core 2.6GHz
2GB DDR2
9600GT 512MB
Native Res 1440x900




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users