SA-MP 0.2.2 R2 Released

04
Sep
2007
By Chris | 4th Sep 2007 at 15:00 GMT in San Andreas | 11 Comments
Since there's no news at the moment I thought I'd update you all on the progress of San Andreas Multiplayer which saw 2 bugfix releases last week. Below is a summary of what's changed and following that are download links.

Version 0.2.2
* Chat window is now scrollable with upto 5 pages of text (50 lines).
* Chat window now wraps text properly over multiple lines.
* Chat entry improved, it allows upto 128 character messages, supports selection, copy and paste etc.
* All text rendering has been heavily optimised. Chat text now has no noticable impact on framerate.
* Name tags cannot be seen through walls/objects.
* A car mod shop crash applying certain car mods has been fixed.
* Pickup limit increased to 400.
* The server can now disable all interior entrances/exits.
* Native sqlite database support for pawn. Sqlite is a lightweight alternative to the mysql plugin.
* The name tag drawing distance can be set from the server.
* Insane stunt bonuses can be toggled on/off by the server.
* Various netcode security updates.
* 0.2.2 will use the second major version of SAC.
* Player head movement sync added. Player's characters will look in the direction their camera is looking.
* A new cellphone action enables players to hold a cellphone and look like they're on a call (useful for pen1 based scripts).
* New usable skins; Tenpenny, Pulaski, Hernandez, Ryder, Smoke, Sweet, Mafia Boss.
* Bandwidth and ped sync improvements. 0.2.2 will consume less server bandwidth than 0.2.1.
* Fixed bug with setting player colors of players 100,101,102.
* Increased timeouts to prevent connection loss.
* Decreased CPU time required to process vehicles on the client.
* Fixed animation problem with fire hydrant and spray can.
* Fixed nametags with no player issue.
* Fixed an issue where the client wasn't displaying "You are banned", "Server is full." messages.

Version 0.2.2 R2
* Some crashes related to models/pickups.
* Collision processing issues (may fall through the ground).
* Chat window wrapping server messages.
* Texture rendering if your graphics card uses a custom d3dx9_25.dll.

I've updated the download page, and you can download SA-MP 0.2.2 from our new downloads database, we haven't quite finished coding it though so I'm giving you a little sneak peek here.

If you're looking for server releases then head over to the SA-MP website.
Join The GTA Place On:
Dazza's photo
Dazza 5th September, 2007 @ 09:18 - Permalink
I was looking for the link yesterday for SA:MP, I'm gonna download this tomorrow. Thanks for the info Chris. (YOUR THE BEST ADMIN EVER)
Noru's photo
Noru 5th September, 2007 @ 12:05 - Permalink
Yeah, I already got this and there are still some bugs that have to be fixed. Anyways a couple severs are still on 2.1 and I noticed you can't connect to them with 2.2
Thomas.'s photo
Thomas. 6th September, 2007 @ 14:44 - Permalink
I'm going to keep with the older SA:MP for a while because I'd rather Play SA:MP Version 0.2.1 until the bugs are fixed in this version.

And the fact i still wan't to go on some of the 0.2.1 Servers
ace_1212's photo
ace_1212 29th September, 2007 @ 08:37 - Permalink
hey, sry this is probly the wrong topic but i newly got GTA SA on the computer so i can play online, i downloaded the client and installed it but it still isnt workin, this mite sound stupid but would it make any difference that i have v2.00 and it says ya should have GTA:SA v1.0 US/EU? if so how do i fix it? lol
TG187's photo
TG187 29th September, 2007 @ 16:21 - Permalink
To play SA:MP, you have to downgrade from V2.0 to V1.0. Here is a downgrader:

http://talidan.littl.../gtasapatch.exe

Hope it helps.
Angry Gorilla's photo
Angry Gorilla 29th September, 2007 @ 16:24 - Permalink
You'll have to downgrade to V1 using the downgrader, I forgot where it was but search around this forum and you might find a link to it.

But back to topic.

I upgraded to 2.2, the only server I ever go on is the AboveUltimate server and you can go on it with 2.2 as well.

EDIT: Curses Spirit 187, you beat me to it.
Anto5640's photo
Anto5640 16th November, 2007 @ 17:15 - Permalink

To play SA:MP, you have to downgrade from V2.0 to V1.0. Here is a downgrader:

http://talidan.littl.../gtasapatch.exe

Hope it helps.


im new to all this mp so if i bought gtasa v2.0 then i need to downgrade it so sa-mp will work?
rockstarrem's photo
rockstarrem 17th November, 2007 @ 19:25 - Permalink
Yes, you will. Use that.
jakt's photo
jakt 14th May, 2008 @ 17:48 - Permalink
gone :( Sa-mp.com is now offline or totally gave up :( verry upset about that. they were doing so well.... sa-mp has gone really far and they just stoped. why is this? does anyone know?
Chris's photo
Chris 14th May, 2008 @ 17:51 - Permalink
Because their "team" isn't really a "team" and apparently shit happened with a couple of the guys in it and it was best just to close everything down...
rockstarrem's photo
rockstarrem 14th May, 2008 @ 21:52 - Permalink
Owned.

Some of our affiliates:

GTAJunkies GTAPSP Grand Theft Wiki Rockstar Nexus RockstarMag.fr Liberty City Survivor

View all affiliates