Sign in to follow this  
Followers 0
Chris

IBStore 3.1 Beta UPGRADED

245 posts in this topic

Good news everyone!

djbob2, the guy who is porting the IBStore mod to IPB 2.1 has finally released the beta version to the public. I've upgraded the store here from Alpha to Beta with no problems.

Please be aware that this is a Beta version, that means it doesn't have as many bugs as the Alpha, but it is still pretty buggy.

Please report any bugs you find in this topic.

I am already aware of:

  1. None of the images work for the items (Yes I am looking for them on my hard drive right now)
  2. There's some weird #124; characters when viewing a category, missing '&' sign from the HTML.
  3. The table on the 'Other Stats' page is messed up.
  4. Stats pages show member's username, not their display name.

Share this post


Link to post
Share on other sites

w00t at progress!

I'll take a quick look and see what's working and what isn't.

EDIT: ER.... Welll, when trying to buy something it says there is a missing file. Also, it lets me see the staff options, but I can't use them. Can everyone see them or is this a glitch?

Share this post


Link to post
Share on other sites

Dunno if it's a glitch. I mean, you are technically staff since you moderate the DS gang sub forum. I wonder??? Wait til some ordinary members post eh.

Oh and the missing file is probably something I've missed uploading. Lemme check that.

EDIT: Yes I did, they're uploaded now. You still get missing file error or not?

Share this post


Link to post
Share on other sites

It said it couldn't use the object or something when I tried buying the Hydra. Tried buying an Infernus and it said the same old "missing object".

I'll try all the objects now.

EDIT: Ok, seems it IS buying the objects, but I'm getting errors. So yeah, it will give you a fatal error, but you're still buying the objects. No cars are there, and the PCJ600 is missing, too.

OH. Turns out I'm buying THOSE, too. It's just giving me errors..... Odd....

EDITEDIT: Name change works. ^_^

Share this post


Link to post
Share on other sites

Um...the quiz table is screwed up. The title for the money column is blank, time left doesn't show a number of days, and nothing at all shows up in the play column.

But I still have all of my money so it's good!

Share this post


Link to post
Share on other sites

Money is going to be recounted later. Based on your current post count. This is to make it fairer because many old members earned so much on interest they maxed out the points table :P

Still gives the old members an advantage in that they'll have been here longer and theoretically will have a higher post count, therefore a higher amount of points. Deservedly so.

EDIT: Points have now been recounted, although it didn't do banked points, so I'll sort that out tomorrow.

As well as reprice all the items in the store, as they're too expensive at the moment.

Share this post


Link to post
Share on other sites
Yeah, no quizes are working so the only way to earn money is posting. It would need 44000 posts to buy a Hydra :o

Lol, nice fact. Though I think all the prices in the shops will be reduced.

'300th Post!'

Edited by K_P

Share this post


Link to post
Share on other sites
  1. None of the images work for the items (Yes I am looking for them on my hard drive right now)
  2. There's some weird #124; characters when viewing a category, missing '&' sign from the HTML.
  3. The table on the 'Other Stats' page is messed up.
  4. Stats pages show member's username, not their display name.

ALL those four bugs above have now been fixed.

DO NOT use your items, the version of PHP we're running on doesn't handle the old code correctly, so nothing will happen at the moment

Quizzes won't function until final release

Anybody care to make miniature thumbnail images of vehicles? We have pictures of EVERY car in GTA3 and Vice City on the website, and two thirds of San Andreas vehicles, you can resize them if you like. This, while I try to make items work on PHP5 for djbob2's benefit and the benefit of hundreds of others who want to use this mod...

Share this post


Link to post
Share on other sites

I can't see the bank either. I click the 'Store' link and everything's there except the bank.

Are the pics supposed to be showing? Because I just see things like; "m60.gif" where the pictures should be.

Edited by JOYA

Share this post


Link to post
Share on other sites

Sweet, I'm the 9th overall richest member. Still, I can't buy anything and some images are on the wrong places. But the bank works fine for me.

Btw what happens when you use an item?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 0