Jump to content



Photo
- - - - -

Draw Distance Refresh Bug


  • Please log in to reply
6 replies to this topic

#1 The JD

The JD

    133 -> Doesn't Take A Genius To Figure It Out!

  • Members
  • PipPip
  • 167 posts

Posted 17 April 2006 - 03:29 AM

Hi! I'm having a few problems with my GTA San Andreas game. First off, I'm not a modder. Although I'd love to be one I just can't get my head around all the elaborate principles involved in the tedious yet rewarding field of modding. Also VB is my language not C++. So go easy on the techno - babble although I'm pretty sure that it shouldn't cause any problems.

Anyways, my copy of GTA: SA is highly modded out. Most of them are car mods but I have got a couple of Building, Weapon and Plane Mods as well. I also edit the GXT files to change the names of the vehicles that I replace. Recently I downloaded and installed a few cars from JVT's latest collection that is on the home page of The GTA Place. It was after I installed these mods that I noticed that when I loaded up my saved game (Doherty: CJ's Garage) the buildings and roads keep appearing and then disappearing randomly.

For Example: I spawn outside the garage facing the railway station. The station takes a second to load up. Until then I can't see the windows, door, the grating on the windows, the row of trees outside the station, the road markings, anything. Once it loads up all of the above come into view but then in another second they all vanish only to start the loading process all over again from the beginning.

It looks like it's a bug with the Draw Distance and I think that it's trying to refresh too many times. It might be caused due to the enormous amount of modifications that I have made to this game. I could be completely wrong though! If you know what is happening then please help me out. This problem shows up in all areas of the game.

Another thing worth mentioning is that a long time ago I got a DrawDistance 10X Mod from here and used it for a couple of days before restoring the original timecyc.dat file. I don't know if this has anything to do with it but I'm just telling you in case it helps.

Anyways, thanks for taking the time to read all of this and if you can help then please do so. i'd be ever so grateful. The following is a list of all the mods that I have made to the game.(Yes, I do keep records.)


Buildings:

Broken Down Garage: Grove Street Autos

Wang Autos: CJ Showroom

Garage Opposite Pier 69: Chrysler Garage

Fire Station (San Fierro): FireHouse

Deserted Airstrip: Modified Airstrip


Planes:

Hydra: All Black Skin

Shamal: Multicolour Skin

AT - 400: Delta 747

Jetpack: New Textures


Cars:

Phoenix = Batmobile

Sabre = Nissan Skyline

Manana = Mini Cooper S

Infernus = McLaren F1 LM

Sultan = Mitsubishi Evolution VIII S

Turismo = Lamborghini Gallardo

Euros = Ferrari Enzo

Blista Compact = Toyota Supra

Regina = Skoda Superb GT

Hotring Racer = Audi RSQ

Bobcat = Dodge Ram

ZR-350 = Mazda RX-7

BF Injection = Ford Mustang SandRoadster

Admiral = Audi RS6 Haze

BF 400 = Honda CBR 600 RR

Mountain Bike = Diamondback Strike

Uranus = Citroen XM

Elegant = BMW 750il

Police Cars = Police Honda Integra

Clover = Dodge SuperBee

Mower = SuperMow

Sparrow = Firebolt

Freeway = Sith Speeder

Banshee = Cadillac Cien

Buffalo = Toyota Supra FnF

Taxi = Skoda Taxi

Elegy = Porsche GT3 Cup

Alpha = Porsche 911 Targa

Blade = Mercedes Benz CL65 Cabriolet

Stretch = Mercedes Benz CL65 Limousine

Picador = Mercedes Benz CL65

Cabbie = Checker Marathon

TowTruck = Chevrolet C20 TowTruck

Yosemite = Chevrolet Silverado

CargoBob = Big Bob

Faggio = Shopping Cart

Primo = Fiat Panda

Comet = Ford Mustang GT Convertible

Windsor = BMW Z4

Club = Honda Integra

Bullet = Ford Mustang GT

Majestic = Porsche GT3

Feltzer = Mercedes 500K

Sunrise = VC Viola II

Bravura = Aston Martin V8 Vantage

Linerunner = Scania 164L 580

Roadtrain = Scania 164L 580 V8

Edited by jd5674, 17 April 2006 - 03:31 AM.

Posted Image

#2 Wheelman101

Wheelman101

    Executioner

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,252 posts

Posted 17 April 2006 - 03:48 AM

might be the cause
1.you have installed too many mods

2.one of your mods might have a major virus/trojen horse/worm

3.you mest up your draw-distance

it might be one of those,did you use a mod installer?
if not then i cant help you srry

Posted Image

hurr De Durr.


#3 The JD

The JD

    133 -> Doesn't Take A Genius To Figure It Out!

  • Members
  • PipPip
  • 167 posts

Posted 17 April 2006 - 03:56 AM

I did use an installer. I used the San Andreas Mod Installer (SAMI). Also how can I have installed too many mods. A mod just replaces the textures of an already existing object. The game should be able to load them up just as it did the old textures. Secondly, almost all of my mods were downloaded from this sitre and I don't think that they are infected in any way. Lastly, if I messed up the DrawDistance, how do I fix it? Can someone post the working files that contain Draw Distance Information?
Posted Image

#4 badgerov

badgerov

    Numbers Runner

  • Members
  • PipPip
  • 124 posts

Posted 22 April 2006 - 02:16 PM

I did use an installer. I used the San Andreas Mod Installer (SAMI). Also how can I have installed too many mods. A mod just replaces the textures of an already existing object. The game should be able to load them up just as it did the old textures. Secondly, almost all of my mods were downloaded from this sitre and I don't think that they are infected in any way. Lastly, if I messed up the DrawDistance, how do I fix it? Can someone post the working files that contain Draw Distance Information?


The only thing that a high number of mods would do is increase the load the game takes on your system. Those new textures are more detailed and much larger files (usually). Its possible that all the extra mods are having that much of an effect on your system.

The fact that 3 of your 5 buildings are in the very close vicinity of where you are spwaning illustrates that possibility in my opinion.

I'm not saying this is the actual cause, its just a possibility. If it started happnening right after you installed JVT's new mods, then try uninstalling those and see if it helps.

And if you think its trying to "refresh too much," turn on the frame limiter in the options.

#5 The JD

The JD

    133 -> Doesn't Take A Genius To Figure It Out!

  • Members
  • PipPip
  • 167 posts

Posted 22 April 2006 - 02:58 PM

The frame limiter option was on. I turned it off and now the problem is slightly better. When I look at a building it takes the game around two seconds to render it.

Here are my system specs:

Windows XP Home SP2
Pentium 4
CPU 3.40 GHz
1 GB RAM

ATI Radeon X800GT 256MB
Catalyst v6.4

I'm running the GTA SA game on display settings:

Resolution - 1280 x 1024
BitDepth - 32
FX - Very High
Anti-Aliasing - 3
Widescreen - No
Draw Distance - Max
Mip Mapping - On
Frame Limiter - Off

Edited by The JD, 22 April 2006 - 03:02 PM.

Posted Image

#6 Slayer

Slayer

    You live only once

  • Elite Members
  • 2,287 posts
  • Croatia 

Posted 23 April 2006 - 04:29 PM

I have a very similar PC configuration and play on the same settings as you do and those are probably mods causing problems. I've also put in lots of mods and the game wouldn't run properly with the frame limiter on. When I turned it off it got from 60-160fps.

Try using Fraps for benchmarking and you might see what the problem is.
<img src="http://img403.images.../cobsignv2.jpg" border="0" class="linked-sig-image" />
<div align="right"><img src="http://img257.images.../pervetnq6.jpg" border="0" class="linked-sig-image" /></div>
+5

#7 Gerard

Gerard

    Underboss

  • Administrators
  • 3,873 posts

Posted 23 April 2006 - 04:42 PM

Which mods had you just installed when this problem started to occur, or has it gradually got worse?

I'm not familiar with the DrawDistance 10X Mod, but was it just a single file replacement/edit, or is there a possibility that you forgot to undo one of the steps?

You shouldn't have any problem on those specs, but I'd suggest just turning down the resolution a bit to see if that helps (800x600x32).

Also try saving your game somewhere else (or using a different savegame) and see if it all loads faster in somewhere other than Doherty.

If it is a case of your game rendering slower than it should, then the problem is probably one to do with configuration.
If it is a case of your game simply not loading some areas at all, then thats a case of something actually going wrong.

Grand Theft Wiki Manager

And not a single fuck was given that day.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users