Sign in to follow this  
Followers 0
MeL

Can't add vehicle components.

5 posts in this topic

So i Originally had a replacement for the Sultan and there was several vehicle components i could add/remove with the trainer and now when i put the same replacement on the SultanRS i am now unable to do so. I can only add/remove 1 component when i know there are 5.

My only reason for switching to the Sultan RS was to have the blow-off valve noise so if there is a way to add this to other cars that would help as well.

Share this post


Link to post
Share on other sites

I can't point you to the source of the problem but from what I can understand you only replaced the Sultan RS's model so obviously it doesn't work correctly...

Ether the parts are in a separate file (doubt it) or the game doesn't recognize the parts cause the Sultan RS normally doesn't have any, except for the hood blower which seems to be on every Sultan RS...

Share this post


Link to post
Share on other sites

I can't point you to the source of the problem but from what I can understand you only replaced the Sultan RS's model so obviously it doesn't work correctly...

Ether the parts are in a separate file (doubt it) or the game doesn't recognize the parts cause the Sultan RS normally doesn't have any, except for the hood blower which seems to be on every Sultan RS...

Well i have installed this same mod on other cars before and had all of the car components before and i have been modding this game for quite awhile so i know i have everything included on. This includes handling changes.

Also when trying another mod that had multiple attachments on the SultanRS didn't work either and i could only change 1 factor. I guess this points out that the SultanRS only allows 1 vehicle component. If anyone knows a way around this or a way to get the blow-off valve sound on other cars, i would greatly appreciate your help!

Share this post


Link to post
Share on other sites

I suggest you add the car instead of replacing an existing one. There's a tutorial on GTAF, don't remember exactly where since I've memorized the process since San Andreas...

Anyway you can change the car's sound in 2 ways:

1. Changing the actual sound, don't know how to do this one for IV yet.

2. Changing the car's ID in the vehicle data file (forgot what it's called by default, I use a self-made one so...), replace it with ''sultanrs'' or whatever the ID for the Sultan RS was.

EDIT: Fount that tut, full of mistakes though so be careful:

http://www.gtaforums.com/index.php?showtopic=420911

The vehicle data file is ''newveh.ide''.

Share this post


Link to post
Share on other sites

I suggest you add the car instead of replacing an existing one. There's a tutorial on GTAF, don't remember exactly where since I've memorized the process since San Andreas...

Anyway you can change the car's sound in 2 ways:

1. Changing the actual sound, don't know how to do this one for IV yet.

2. Changing the car's ID in the vehicle data file (forgot what it's called by default, I use a self-made one so...), replace it with ''sultanrs'' or whatever the ID for the Sultan RS was.

EDIT: Fount that tut, full of mistakes though so be careful:

http://www.gtaforums...howtopic=420911

The vehicle data file is ''newveh.ide''.

Alright, i'll experiment with these. Thanks!

EDIT: Alright, i figured it out. I put the mod back on a car that worked and in vehicle.ide i changed the vehicle name to SultanRS which gave it the same engine noises as the SultanRS.

Edited by MeL

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0