Sign in to follow this  
Followers 0
spike123131

San Andreas not working on Windows 7 OS

5 posts in this topic

I know this is a common problem, yet I can't find anyone who has the exact problem as me. I'm running Windows 7 Home Premium 32bit on a Toshiba Satellite L505. I've tried a lot of things already to make San Andreas work, but nothing helps. I know the system requirements are working because I play other games that are much larger than San Andreas that work (gmod 11, TF2, etc.) So if you have anything to say, please do, thank you for your help in advance.

Share this post


Link to post
Share on other sites

I am running windows 7 64bit and it works fine on my OS.. Did you try running as administrator? also can you been more specific, like what happens when you try to load the game up does it just not do anything?

Share this post


Link to post
Share on other sites

Have you tried adding it on the Data Execution Prevention whitelist? There are some instances wherein SA would suddenly crash on load, especially if you're using mods like CLEO.

Share this post


Link to post
Share on other sites

I tried it on both Win7 and

For some reason it works now. It would crash on startup. And it was clean, too.

Yeah that happens. Try running it in compatibility mode with Windows 98, fixes a lot of random problems.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0