Jump to content



Photo
- - - - -

Simple Native Trainer freezing, blurry Roads and disappearing buildings

with car mods in GTA IV

  • Please log in to reply
3 replies to this topic

#1 DJ_Guttah

DJ_Guttah

    Nobody Special

  • Members
  • 2 posts
  • United States 

Posted 16 August 2011 - 07:17 AM

Hi, I have come here for help since NO OTHER WEBSITE KNOWS HOW TO FIX THIS.

Whenever I play GTA IV 1.0.7.0 (steam version) and GTA EFLC 1.1.2.0 (CD version) with car mods, if I install more than 4 car mods, or if I install a car pack, the roads always disappear and the buildings always disappear and it's so annoying. When this happens, I can't spawn any cars from the Simple Native Trainer, and Simple Native trainer freezes.

Is there anybody, I mean anybody out there that knows how to solve this problem? This has been driving me insane ever since i got this game nobody will help everyone is CLUELESS

Here are the mods I'm using:

1. Rextex128's car pack (a guy from youtube)

2. ENB Series 0.082 rextex128 settings

3. Better City Textures (7GB of textures)

4. Road Textures by Fonia

5. ELS police lighting system v5

Let me clear up a few questions you may have

1. Yes I've tried turning down my settings, it DOES NOT WORK. So don't recommend that I turn down my settings.

2. I'm pretty sure my specs EXCEED the recommended requirements for this game. Core i5 Sandy bridge, GTX 580, 8GB of ram....

3. Reinstalling default cars fixes the problems, but I don't want the sh*tty default cars.

Sorry if I come off as rude, but I am just so frustrated. I have constantly been restarting GTA IV, constantly reinstalling this crap, and nothing that I try seems to work, and the menu music is beginning to DRIVE ME INSANE.

Please help me before I put a gun to my head I swear

Edited by DJ_Guttah, 16 August 2011 - 07:20 AM.


#2 TUN3R

TUN3R

    Executioner

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,569 posts

Posted 16 August 2011 - 08:38 AM

The default cars are shitty? Do they break your game? Don't think so. The modded ones are shitty cause they are made by a bunch of 40 year old piss lickers who live in their mom's basements.

Now, I'd be happy to let you blow your brains out but probably the only reason why I'm still here is cause I'm not completely useless...

Way I see it, your game is running out of memory (it doesn't matter if you have 2GB or 8GB, the game has a specific amount it's allowed to use). And those right there are quite a lot of mods... I'm guessing your game is pushed to the limit with all those graphics mods (7GB of textures, didn't know that was even possible), so it's enough to install just one car to go over the limit.

I guess giving up some mods is out of the question, if that's the case then there are ways to allow your game to use more memory than allowed by default, just be warned that doing this might eventually come to bite you in the ass as well, like it did with me when I had a 32bit OS. Someone told me that a 64bit OS will respond better to memory tempering, I personally don't wanna take the risk with this since the only way to fix it is to reformat the PC. Use with caution:

1st thing you have to do is create a notepad file in the GTA IV / EFLC main folder (next to the other files and folders) called ''commandline'. Then enter these in it:

-nomemrestrict
-percentvidmem 100
-noprecache
Also use -norestrictions if you think your GPU is good.

Then disable DEP. You can do this by right clicking on Computer > Properties > Advanced System Settings > Advanced > Performance > Data Execution Prevention and add GTA IV to exceptions. DO NOT disable DEP for all the programs, it will be instant PC rape.

There's a chance GTA IV might not work with DEP disabled, if your game crashes at the start or doesn't launch at all go back to DEP and re-enable it.

Again, I can't guarantee these will work, those are quite a lot of mods you have there, no game was made to support this many...

PS: Native needs a lot of memory to work, and since you're running out of it Native can't really do it's job.

Edited by TUN3R, 16 August 2011 - 08:42 AM.


#3 DJ_Guttah

DJ_Guttah

    Nobody Special

  • Members
  • 2 posts
  • United States 

Posted 16 August 2011 - 06:59 PM

If this doesn't work, will getting more system ram solve the problem?

And the options for disabling DEP are transparent/washed out and I can't change the settings.

It says "I must be computer Administrator to change these settings." But I am, wtf?

Edited by DJ_Guttah, 16 August 2011 - 07:39 PM.


#4 TUN3R

TUN3R

    Executioner

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,569 posts

Posted 17 August 2011 - 12:12 PM

Yeah I have that problem too, don't know why or how to fix it.

Anyway no, getting more RAM won't help since you already have more than needed. Disabling DEP is your best chance, long as we can find out how to disable the administrator crap...




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users