Jump to content



Photo
- - - - -

GTA III Problem(s).


  • Please log in to reply
2 replies to this topic

#1 TUN3R

TUN3R

    Executioner

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,569 posts

Posted 20 November 2010 - 11:35 AM

Kay so I recently got the GTA collection from Steam for 7$, best deal of my life, I now own all GTA's up to Vice City twice and GTA San Andreas 3 times (once on PS2) :D

So anyway I was getting all nostalgic n' shit and decided to re-play each and every one of them (except GTA1 and GTA2, lol). I started with GTA III and it seems to have a few problems:

1st the radio stations are missing. I know the radio stations have always been tricky in GTA III but I honestly don't remember how I fixed it...

2nd problem are the physics and maaaan are they broken... random stuff keeps happening but what annoys me most are the fact that cars can't seem to go in reverse, I keep holding S and although the wheels spin and the lights flash the car just seems to do a reverse burnout... sometimes, other times works, random. Another kick in the balls would be the actor physics, for example: I started running from cops near the Pay N Spray in Red Light and I suddenly jumped from the sidewalk to the lower section losing half of my HP (don't even remember that being possible, good ol' days when you could jump off a building and only lose 10 HP). And that's not even the worst example, can't even say how many times I got randomly killed by map slopes and stuff.

3rd problem are the cheats, they don't work.

And finally the blood... there doesn't seem to be any...


My PC:

Intel Core i5-661 3.33GHz (core-duo)
4GB RAM (2GB in use cause of 32b OS)
GeForce 9400GT 1GB
Windows 7 Ultimate 32b

I tried running both the Steam version and my disk version which I managed to dig out. I could always pirate it since I already own the game twice but this got me banned from NFScars so forget I said that...

Solutions?

PS: This is the 1st time I tried running GTA III or Vice City on this PC, GTA San Andreas and SA-MP work fine.

#2 Masked Marauder

Masked Marauder

    Fairweather Fiend

  • Members
  • PipPip
  • 173 posts

Posted 03 March 2011 - 11:25 PM

Problem solved yet?

#3 TUN3R

TUN3R

    Executioner

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,569 posts

Posted 12 April 2011 - 04:21 PM

Problem solved yet?


Yes, turned frame limiter on.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users