Jump to content



Photo
- - - - -

MTA Video Uploader bugs etc.


  • This topic is locked This topic is locked
41 replies to this topic

#1 Chris

Chris

    Limbal Rings

  • Administrators
  • 10,939 posts

Posted 07 March 2009 - 06:50 PM

ONLY REPORT BUGS HERE PLEASE. Go here to upload your videos.

So I was browsing through the MTA topic and noticed some of you complaining about YT not allowing music in your videos and such. It's possible that we can allow video uploads directly to TGTAP, we have our own skinned media player and everything ready. It's just a case of me getting round to installing the software on the server.

ImageLodge actually uses the software for video uploads but due to the way it's coded it's difficult for me to make a simple BBCode for it on the forums, and I'm not enabling HTML posting for normal users. But if we did it here directly at TGTAP here, I could make a simple bbcode like [tgtapvid ]video id here[/tgtapvid] and you could all use that to post your vids.

Let me know if this is something you might be interested in.

#2 Spider-Vice

Spider-Vice

    Pest Control

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 7,019 posts

Posted 07 March 2009 - 06:58 PM

It is actually a very good idea, people could put [tgtapvid] or something else and the the ID in the middle or whatever (I never uploaded Videos on ImageLodge :P)

Posted Image


#3 Mpilk901

Mpilk901

    Proudly destroying the community since March '07.

  • Elite Members
  • 2,505 posts
  •    Scotland 

Posted 07 March 2009 - 07:13 PM

If this was introduced I might be interested in making MTA videos. It seems like a good idea to me.

Nothing to see here, move along


#4 MrLlamaLlama

MrLlamaLlama

    Graphic Designer.

  • Super Mods
  • 4,819 posts

Posted 07 March 2009 - 07:15 PM

Do it. I'll have to find out why my videos come out in funk colours first, but t'would be awesome.

Posted Image


CoolerMaster HAFX Tower Case | XFX 850w Black Edition PSU | Asus CrossHair IV Formula Motherboard | AMD Phenom II x6 3.4 @ 3.7 Ghz + ThermalTake Frio HS/F | 8Gb Corsair Dominator GT | Nvidia/EVGA GTX470 1280Mb | 64GB Crucial RealSSD (os) | 2x 1TbSamsung Spinpoint F1


Need a quick GTA Fact Fix? - Grand Theft Wiki it!


#5 Mpilk901

Mpilk901

    Proudly destroying the community since March '07.

  • Elite Members
  • 2,505 posts
  •    Scotland 

Posted 07 March 2009 - 07:19 PM

Llama do you have the same problem with screenshots? Because when I screenshot on MTA mine just comes out in a colourful fuzz.

Nothing to see here, move along


#6 rockstarrem

rockstarrem

    #SocialMediaPresence

  • Super Mods
  • 4,254 posts
  • United States 

Posted 07 March 2009 - 09:25 PM

Obviously do it etc.

#7 GTA Don

GTA Don

    It was a good day.

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 3,605 posts
  •    England 

Posted 07 March 2009 - 09:50 PM

I would definitely start getting interested in MTA again if this were to happen. I love making videos and taking screenshots.

Ermm...



#8 TM™

TM™

    Need new model for avatar :P

  • Elite Members
  • 6,334 posts

Posted 07 March 2009 - 10:10 PM

Do it. Do it. Do it. Do it. :P

Yes, it would be an awesome thing to have, I hate YT and it's muting thing. Only a 10 second clip of music, which doesn't even last that long, and they mute it. Seriously, I hate that. Would be fun as well, since we start up some funny gangs up (e.g. Clowns gang, Cluckin' Bell clans etc.).
Posted Image
TM™ - Elite.

#9 Chris

Chris

    Limbal Rings

  • Administrators
  • 10,939 posts

Posted 07 March 2009 - 11:06 PM

Alright then I'll install the software on the server and get it all ready.

#10 Chris

Chris

    Limbal Rings

  • Administrators
  • 10,939 posts

Posted 08 March 2009 - 04:52 AM

Can someone quickly upload a small-ish video here to test this out: http://www.thegtapla...videoupload.php

Should be working fine but people in my house have decided to seed torrents overnight and are using up all the upload speed so now I can't test it myself. If there's any errors hit me up on MSN, otherwise it should be working fine and you can all use it.

#11 NotYouHaha

NotYouHaha

    Ronin

  • Members
  • PipPipPipPipPipPip
  • 573 posts

Posted 08 March 2009 - 05:13 AM

Can someone quickly upload a small-ish video here to test this out: http://www.thegtapla...videoupload.php

Should be working fine but people in my house have decided to seed torrents overnight and are using up all the upload speed so now I can't test it myself. If there's any errors hit me up on MSN, otherwise it should be working fine and you can all use it.

Alright, I uploaded a little video of the awesome MTA menu screen. Was only 2 seconds, it said it took over 1 minute to upload, though.
Then, this happened.
http://i290.photobuc...icture001-2.jpg
That was an AVI video from Fraps, btw.


And, the system allows you to upload any file, so if I try to upload a picture named "Picture 001", this will come up:
http://i290.photobuc...icture002-1.jpg

EDIT: Changed file type to .wmv and it uploads successfully.

Anyone getting the "Video not found: /media/videos/mta/test-1236492543.flv" error on my video?

Strange, still not working. Maybe it's my Fraps. I'll troubleshoot tomorrow.

Edited by NotYouHaha, 08 March 2009 - 06:51 AM.


#12 Chris

Chris

    Limbal Rings

  • Administrators
  • 10,939 posts

Posted 08 March 2009 - 05:25 AM

Ok I've made it so only valid video files can be uploaded now, you'll simply get an error if you try to upload other stuff.

The first error you got shouldn't have happened, I left the code in since I can't see anything wrong with it but the error message is suppressed so it won't show up on the page.
Can someone try again and see what results they get. Thanks.

#13 EvoLuTioN

EvoLuTioN

    Call me Evo ...

  • Members
  • PipPipPipPipPipPipPipPip
  • 2,442 posts

Posted 08 March 2009 - 05:32 AM



Okay here goes, not a mta vid but only vid I had. Converted it to a low low quality.

Dit: Anyone else getting error #20225 something?

Dit again: Nevermind, works now

Ninja admin edit: Sorry Evo I messed up the BBCode thing so I was just fixing it, that error was nothing to do with the video upload. Seems to be working fine :D

Edited by Chris, 08 March 2009 - 05:46 AM.

Reality - An illusion caused by Alcohol Deficiency

Posted Image
xfire|Steam ID : evolutionevoz


#14 Huckleberry Pie

Huckleberry Pie

    "There's always something,"

  • Members
  • PipPipPipPipPipPipPipPip
  • 2,978 posts
  • Philippines 

Posted 08 March 2009 - 05:39 AM

Currently testing an MPEG video; it isn't an MTA vid, but since this is just a test of Chris' PHP script, I thought of posting it for beta purposes...

Any more and we'll beat YouTurd!! :awesome:

EDIT: Here's the video:


Edited by Huckleberry Pie, 08 March 2009 - 06:01 AM.

Posted Image

Ubisoft should take a look at this...
"We love Him because He first loved us." - 1 John 4:9-10


#15 EvoLuTioN

EvoLuTioN

    Call me Evo ...

  • Members
  • PipPipPipPipPipPipPipPip
  • 2,442 posts

Posted 08 March 2009 - 05:46 AM

Lol Ninja edit fail, :P Anyways the clip works fine now, I like this upload better than youtube, it has an actual working progress bar!!!
Will there be a upload limit for each user? Maybe a new Video tab in the members profile?

Btw w00t first Vid uploader x2 xD win,etc

Edited by EvoLuTioN, 08 March 2009 - 05:48 AM.

Reality - An illusion caused by Alcohol Deficiency

Posted Image
xfire|Steam ID : evolutionevoz


#16 Chris

Chris

    Limbal Rings

  • Administrators
  • 10,939 posts

Posted 08 March 2009 - 05:52 AM

Alright thanks everyone who's helped test it. Seems to be working fine now.
I fixed an error in the BBcode so when you use it it'll have a still image in the background rather than plain black.
Yes we have a progress bar. YT fails so hard by not having something so simple like that.

At the moment there are no limits as I've no idea how much this thing will be used.
BTW, if you try to upload a video more than 100MB in size then it will fail... though if you cannot compress a video below this then let me know and I'll raise it if we need to.

I'll let you all test this thing out for now, and sometime tomorrow I'll remove everyone's tests and just leave the actual MTA ones if any are uploaded.

P.S. It's probably best to capture video using Fraps as it seems to process it fine, Sherman uploaded a video he captured through Xfire and it just throws errors, seems they use a weird codec.
You can upload pretty much any video format, though I've limited it at the moment to the following common ones. I don't see why you'd be using anything else so this should be fine: "avi", "mpg", "mpeg", "wmv", "flv", "mov", "divx", "mp4", "mkv"


@NotYouHaha: Not sure why your videos keep failing but I manually ran the command to convert them and they were fine :/


All uploaded videos can be found here: http://www.thegtapla...edia/videos.php

#17 Spider-Vice

Spider-Vice

    Pest Control

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 7,019 posts

Posted 08 March 2009 - 02:57 PM

Here's some shit I made to test the uploader:



EDIT: WTF, Video not Found?

Edited by Spider-Vice, 08 March 2009 - 02:57 PM.

Posted Image


#18 rockstarrem

rockstarrem

    #SocialMediaPresence

  • Super Mods
  • 4,254 posts
  • United States 

Posted 08 March 2009 - 03:03 PM

Owned.

Chris you should make a little admin script for this.

#19 Mpilk901

Mpilk901

    Proudly destroying the community since March '07.

  • Elite Members
  • 2,505 posts
  •    Scotland 

Posted 08 March 2009 - 03:07 PM

Huck, wtf?

This is cool, I'll download fraps or something and will take some interesting clips. If I get round to it I'll make a short video.

Nothing to see here, move along


#20 Alvas.

Alvas.

    Stay Cool !

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,272 posts
  • India 

Posted 08 March 2009 - 04:44 PM

Great i will make some soon guys better than YT !

Posted Image

Posted Image





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users