Jump to content



Photo
- - - - -

GTA IV patch to be released in next few days


  • Please log in to reply
11 replies to this topic

#1 Chris

Chris

    Limbal Rings

  • Administrators
  • 10,938 posts

Posted 06 December 2008 - 03:58 AM

It seems the outraging gamers have got to Rockstar Games, and they've finally put a public face on things and made a post over at GTAForums. The Rockstar Toronto 'spokesperson', who by the way is still adamant that only "several users" are experiencing problems despite all GTA forums being full of complaining users, assures us that a patch will be coming in the next few days that sorts out some of the issues players are having. Additionally, nVidia and ATi appear to be preparing updated driver releases which supposedly help the game run better.

We are working on making a patch available in the next few days. Since Grand Theft Auto IV is a Games For Windows – Live game the patch must be certified by Microsoft before release. The patch is already at Microsoft and we expect a speedy approval.
The patch contains a variety of fixes including:

-A fix to the crash after legal screen that some German customers were reporting.
-Numerous improvements to the video editor: Smarter naming of videos, improved rendering quality, better fx during replays
-Fix to bowling while using certain sensitive mice
-Fix for ATI 1900 shadows
-Overall savings to memory
-Graphic improvements to particle systems and mirrors
-Multiplayer character settings are preserved
-Support for DirectInput controllers. Note: The current hack way of supporting these controllers may not work with the improved functionality. So we recommend you remove the hack before upgrading to the patch.

Issues with power management software have also been fixed (slow speed, double speed issues). Even after the patch comes out setting power management software to maximum performance is recommended. We’ve seen cases where power management software does not detect the game is running and puts the CPU in green mode.

Besides the patch we’ve also improved the way the Social Club handles data this should have greatly reduced or eliminated the Mma10 error. If you are still receiving this error after logging in and out of Social Club we would like to know as much info as you can about it.

They also provide information on where to get updated graphics card drivers:

We’re pleased to announce that in co-operation with Nvidia a new driver has been released that improves performance and fixes a major issue with 7900 series cards. If you haven’t gotten the driver yet download it here: http://www.nzone.com..._downloads.html

ATI has also agreed to officially release Catalyst 8.12 which will release on Dec 10th from http://game.amd.com. Expect significant performance improvements when using this new driver.

Great to see that they're busy working on patching the game up fairly quickly to keep us all happy. Let's hope it works!

#2 Blur

Blur

    Headhunter

  • Members
  • PipPipPipPipPip
  • 519 posts
  • United States 

Posted 06 December 2008 - 04:10 AM

Good news to hear for the anxious PC users. Hopefully this will lessen the negative activity on forums.

#3 chris82

chris82

    Modding King

  • Elite Members
  • 2,917 posts

Posted 06 December 2008 - 04:20 AM

Awesome, awesome to the max. This game has so much potential and it's sad to see it have bad things associated with it.


Posted Image
Posted Image
Summary of TGTAP
This signature does not display correctly on Internet Explorer 6 or lower.


#4 Righty

Righty

    *lurks*

  • Elite Members
  • 1,962 posts
  • United States 

Posted 06 December 2008 - 05:17 AM

Great! Can't wait for it to be released

#5 Earthbound

Earthbound

  • Elite Members
  • 950 posts
  • Australia 

Posted 06 December 2008 - 05:35 AM

Fantastic. The solution to a problem that never should have been there. I'll stop being a prick now, I think.

Posted Image
I hate to be the one to break it to you, but a clear conscience
is generally the result of a faulty memory, not a faultless life.
Want a new sig? Click here!
GET ON MTA


#6 Mehhh

Mehhh

    Trickster

  • Members
  • Pip
  • 95 posts
  • United States 

Posted 06 December 2008 - 05:42 AM

I've not been too happy w/ my experience for sure! I plunkt down cash early Nov & traded in some games for a credit towards it..

I'm kinda sittin here dumbfounded.. I'm not really sure what to say.. I started out w/ gettin the game last week when it was released, & first load problems and only now 4 days after getting it, does it look like I MAY be able to play it ?? I was pretty tickt about some things ..

I've spent much more time reporting problems, searching for answers across the net & asking for help that I dont get... I had thought I dint have enough system RAM, figuring I may never get it to play w/ out buying new larger capacity modules ...... I had found some articles of help, one on RS's site about the graphics tuner as maybe the reason for missing textures, I did have one but had uninstalled it b4 reverting, I guess ??

I've since restored my pc to a date predating the tuner ... I've uninstalled, reinstalled drivers again and again, updating.. finding now some progs I can't uninstall ..
I then reinstalled GTA IV, had to TRY to activate it manually since it could not be revoked since it now said "the application is not activated...", well I went through the manual activation successfully only to have it give me a "RGSCLauncher stopped working, search online for a solution" when I tried to play...

So, I thought maybe a reinstall will fix it, uninstall, reinstall, same problem...
Nothing worx..

So, I've been reading for hours on diff sites, someone mentioned something about running GTA IV "-windowed" from a shortcut of GTALauncher on the desktop... THis did not work for me, RGSL reported error again ..

Well, as odd as it sounds.. I decided to make a shortcut for RGSCL and decided heck I'll "-windowed" it.. I dbl click, it opens & runs, I skip login, sign in to WGLive, install update, restart, I get into the game!!!!!! ATLEAST FOR NOW ....

I can now see everything like it was the first time I installt the game 4 days ago...
I took ROman to our safehouse, left on foot, running up the hill, guess what, pillars to the subway started to disappear, other objects, here a pic

This is what I saw
http://img247.images...ashagainmt1.jpg

Just like the first thing I seen on first load, yet there was no sign of any tuner adjustments on my pc this time, so I'm not so sure RS's suggestion was 100% dunno

Then get this, I paused to paste that screen into Psp and when I finisht and went back in game, this is what I saw

http://img247.images...shagain2tp7.jpg

Yea, stuff started to reappear and remained mostly.. seemt like a memory thing ? what about Vista's prefetch, it fills mem w/ data it "THINKS" you will use soon, maybe this creates that "memory leak" some say, I dunno..

Well, those were the original settings the game loaded, I then turnt off the "clip" I dont know if that really had any effect and dont know my frame rate but its not too bad, I find it pretty good, it only gets a lil slow when there is ALOT of stuff in the screen..

I snapt this pic w/ the following settings I changed to (keep in mind I had to cut the size in half & the image was snapt at 1440x900

http://img389.images.../gtahuh1gv4.jpg

My resolution is 1440x900, 60Hz
View distance 37
Detail distance 99
Vehicle detail 99
Shadow 5
Vid mem used 468MB

I'm hoping for the best from now on, unless I hear diff, I'll proly procure new sys ram..
I'm glad RS is gettin on topa things to address these issues, everybody knows its a popular & cool game, everybody jus wants it to work right..
Its harder to develop a game like this across so many systems specially w/ security built in etc.. I do think it could've been more well-tested but heck we wanted it, they tried to deliver ...
Vista Premium 32bit
Dual core 2.6GHz
2GB DDR2
9600GT 512MB
Native Res 1440x900

#7 rappo

rappo

    Professional Dumbass

  • Members
  • PipPip
  • 169 posts
  • No Flag 

Posted 06 December 2008 - 06:59 AM

That is one of the funniest forum threads I've seen in a while. Some poor soul from Rockstar Toronto is trying to be a hero and all those asshats keep posting about how Rockstar fucked up.
Posted Image

#8 Nate10

Nate10

    Underboss

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 3,937 posts

Posted 06 December 2008 - 08:01 AM

Good to hear. Probably'll get IV for the PC once I hear the patch saved the day.

#9 TM™

TM™

    Need new model for avatar :P

  • Elite Members
  • 6,334 posts

Posted 06 December 2008 - 05:08 PM

I think PC gamers need to realize:

That Rockstar aren't gods. In fact, they're game developers, just like everyone else (This includes EA and many other companies). They will in fact make mistakes like this, games aren't all this good, so expect it to be like this. Games like this aren't meant to be good on PC, some are pretty awesome on consoles only. Of course, Rockstar said it "Ran beautifully" on their PC, so I guess it should of been beautiful, not a crisis.

But this is a chance of recovery for them, hopefully more patches will do good to it as well, and hopefully will fix all the problems everyone gets. (It may not, but mainly these major bugs/glitches that happen most of the time).
Posted Image
TM™ - Elite.

#10 Mehhh

Mehhh

    Trickster

  • Members
  • Pip
  • 95 posts
  • United States 

Posted 09 December 2008 - 04:08 PM

Well this is the first time they've put GTA on the pc at this scale, not the first of the series for pc but of this scale, so frankly, while I try to sympathize, I think maybe they shoulda/coulda done more "homework" b4 setting it on this platform, its not like this is their first intro for the pc platform, BUT as I said b4, as an example, a 100 million consoles all w/ the same hardware & software is different than a 100 million pc's w/ varying hardware/software configurations!

Regardless of what they say, the statement that it "ran beautifully on our system" isnt a valid selling point for sure, since first no one knows their system specs and most proly can't afford it, all the more reason why they had apparently said to some degree that the higher settings were for "future pc's" to take advantage of.
Vista Premium 32bit
Dual core 2.6GHz
2GB DDR2
9600GT 512MB
Native Res 1440x900

#11 claude-5

claude-5

    UK have the $ on their keyboard, so why dont US have the £

  • Members
  • PipPipPipPipPipPipPipPip
  • 887 posts

Posted 09 December 2008 - 11:50 PM

im not experiencing any problems, settings,

My resolution is 1024x768,
View distance 2
Detail distance 2
Vehicle detail 2
Shadow 1

card: nvidia geforce 9800GT 1GB

and my mate wiv a 256 mb onboard intel card, not moan bout something like this although, laaaaaags like hell, its like 1 fpm(frame per minute lol),

what exactly are these issues, pop-up objects?

Posted Image

TOXIC worked on this sig, and im greatful :D


#12 Mehhh

Mehhh

    Trickster

  • Members
  • Pip
  • 95 posts
  • United States 

Posted 10 December 2008 - 03:51 AM

O, well as for popups I was just refering to the social club sign ins and ofcourse the not signed into windows lived stuff you have to get through EVERY TIME YOU LOAD, sheesh ..

As for problems, I dont know, I dint design the game or components in my pc.. All I can say is what happens, what I see etc.. In the beginning it was really fubar .. updating everything made no notable difference.. The RGSCLanucher still wont work right but the one in the 1_0_0 ... folder works perfect, its jus the one in the "rocksta social club" itself that doesnt, its the one thats defaulted to autostart w/ windows ..

I jus created a shorcut from the other one & use it to launch.. Now I've been trying to mod a lil w/ no success :\ I have the retail as opposed to dlded from steam etc .. Folks are hard at work on solutions however .. I've seen a new OpenIV prog that "eagle.." posted a link to, when its finisht, it loox to be a cool prog..

I DID have my pc running pretty high Claude, I had render on highest, & then following your stats in order, I had 1440x900 resolution, 37, 99, 99, 5 .. Gph mem useage was about 3?? MB out of avail 491MB.. Believe it or not it was workin and lookin great, jus eventually textures wouldnt show up so I had to back it all down, which is kinda doofy since part of the hype for the game was the high graphics over console but heck if ya cant use em w/ out a $5000 pc, whas the point heh.. They say the pc lower settings beat the console, doesnt look like it to me .. loox worse..
Vista Premium 32bit
Dual core 2.6GHz
2GB DDR2
9600GT 512MB
Native Res 1440x900




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users